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Introduction 

 
The construction industry is split up in many separate providers, from designers up to building part 
suppliers; each party is using software for different tasks (design, costs, detailing, fabrication…). Today 
we are aware that a major part of the inefficiency in construction comes from inadequate cooperation 
between the construction partners, resulting in errors, repetitive work, extra costs etc. 
 
There are solutions to improve fundamentally the cooperation between construction partners, even with 
each party keeping its own existing software. If we agree on how to exchange information, if we use 
digital 3D models of structures, if we use standard exchange formats and if we can control the workflow 
between project partners, then we all win. 
 
This course document will explain the different methods for exchanging SCIA Engineer models with 
other software applications. Also different methods/workflows will be discussed in order to obtain a 
good model exchange between SCIA Engineer and other software applications.  

Modules 

The modules that are needed for importing/exporting data to and from SCIA Engineer in this course are 
the following:  

- REVIT Structure Interface: esa.21 

- TEKLA Structures Interface:  esa.22 

- BIM and Workgroup toolbox: esa.26 

- Etabs interface:  esa.29 
 
These modules are included in the Structural Edition module set or they can be bought as separate 
modules. 
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Part 1: Exchange via OpenBIM (IFC) 

OpenBIM 

  
Open BIM is a universal approach to the collaborative design, realization and operation of buildings 
based on open standards and workflows. Open BIM is an initiative of BuildingSMART and several 

leading software vendors using the open BuildingSMART 
Data Model. 
 
The Open BIM Program is a marketing campaign initiated 
by SCIA, GRAPHISOFT, Tekla, Allplan and other 
members of BuildingSMART to urge and facilitate globally 

coordinated promotion of the Open BIM concept throughout the AEC industry, with aligned 
communication and common branding available to program participants. 

IFC format 

Industry Foundation Classes, IFC, are the main BuildingSMART data model standard to facilitate 
interoperability in the architecture, engineering and construction (AEC) industry. The IFC format is 
registered by ISO as ISO/PAS 16739.  IFC is used to exchange and share BIM data between 
applications developed by different software vendors without the software having to support numerous 
native formats. 
 
As an open format, IFC does not belong to a single software vendor; it is neutral and independent of a 
particular vendor’s plans for software development. The advantage of a neutral data format is that 
problems that may occur when data are exchanged and converted to a different format can be reduced 
to a minimum. In addition, all those involved in a project can choose the software they need. The only 
requirement is that the software has an IFC interface. 
 
This IFC-interface is included and certified in SCIA Engineer. 

 
 
BuildingSMART International awards SCIA nv as the first company to pass the 
certification of the interoperability standard IFC 2x3 “Version 2.0” for structural 
model exchange with SCIA Engineer, as was announced during the 
international BuildingSMART meeting in Waltham (Boston, USA), 11-15 March 
2013. 
 
 
 

 

 
The “IFC Certification 2.0” is an improved implementation of the former “IFC2x Certification” procedure. 
The most important achievement of the “IFC Certification 2.0” procedure is a detailed quality control 
approach for the IFC interfaces on top of the self-check performed by the software developer. 
 

IFC CoordinationView 2.0 

CoordinationView or in short CV (2.0 is the current version for IFC2x3) is the most common subgroup. 
CV includes all components and architectural elements as 3D solids with their characteristic values and 
attributes. IFC CoordinationView includes and supports architectural components and MEP 
components, such as walls, columns, beams, pipes, ducts and switches. 
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During transfer, all elements get a unique ID. In addition, you can give elements an unlimited number 
of additional pieces of information. 

Roundtrip versus Reference Model 

Opinions about the meaning of the term BIM differ widely; its ideas and underlying philosophy are 
interpreted differently.  
 
Many publications mention the so called ‘roundtrip’ workflow where an IFC model  is imported and 
exported in a chain of software applications. Via this concept you should expect that the IFC model at 
the end of the chain should be identical to the one at the beginning. But because the IFC data model is 
not always restrictive, and software implementations are never 100% correct, this roundtrip will 
probably never work to its full extent. 
 
In practice users solved this issue via the following argument: nobody needs the whole model and 
everybody takes responsibility for their own data, which is (conceptually) a part of the central data 
repository. By sharing and synchronizing a subset of their own model instance to the central data 
repository the users do not aim to create a prefect BIM model, but focus on doing a good engineering 
task. Users can import the IFC model from the central data repository to their software application as a 
‘reference’ during engineering/design. After the user (MEP engineer, Structural engineer,…) has 
performed its engineering tasks on the model, then the model can be exported back as a new IFC 
model into the central data repository. 
  

 
This concept is not new and often referred to as the use of ‘reference’ models. The concept is 
illustrated in the figure above. More information about new insights via IFC model exchange can be 
found in reference [1]. 

IFC in SCIA Engineer 

IFC models can be imported into SCIA Engineer or the other way around SCIA Engineer models can 
be exported to IFC models. 
 



Integration with BIM workflows – SCIA Engineer 17 

8 

Shape representations: 

Before explaining on how to exchange models via IFC, information will be given on how to represent an 
element (shape representation) via IFC.  

1) Sweptsolid 

Via Sweptsolid a profile or a plane is defined and extruded along a curve/axis. Elements that are 
defined in within an IFC via a Sweptsolid representation are converted after import to native SCIA 
Engineer 1D-/2D-members. 
 

Example of a sweptsolid      representation of 
an I-profile: 

Example of a sweptsolid representation of a slab: 

 

 

 
An IFC-file composed via a Sweptsolid representation can contain geometric information such as: used 
cross-section, slab thickness,… In the picture below you can see an IFC-file that is opened in an IFC 
viewer (Solibri Model Viewer), the used cross-section is mentioned in the column property. 

 

2) Boundary representation (Brep) 

Via Brep an entity is described with vertices that are interconnected with lines in order to represent a 
volume. These entities are imported in SCIA Engineer as general volumes (= solids). In that case the 
member recognizer can be used for a conversion from general solids to a native SCIA Engineer 1D-
/2D-members. The downside of a boundary representation is the lack of any information concerning 
the slab thickness, 1D member cross-section. This can be seen in the picture below in which no 
information about the used cross-section can be found. 
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3) Sectioned spine representation 

Beams with haunches or arbitrary beams can be represented via a sectioned spine 
Example of an arbitrary 1D-member with a sectioned spine representation:

 

Beam and column profiles 

After import the beams/columns can have one of the following cross sections: 

- Cross-sections from the profile library – if the same name is found in the SCIA Engineer database. 

- Geometric shape cross-section – if the cross-section is defined with parameters in the IFC-file 

- General cross-section 
 

 

Example of a parametric cross-section: Example of a general cross-section: 
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Import procedure: 

1) Open SCIA Engineer 

2) Go to File > Import > IFC 2X3 

  

3) Select an IFC-file in Windows Explorer and confirm by clicking on “open” 

4) Select the import options you want to use. Confirm by clicking on OK to start importing the project. 

 
 
Import options: 

- Import entities 
You can manually select which objects (1D member, 2D member,…) in the IFC-file should be 
imported in SCIA Engineer. 

- Tendons 
Tendons in an IFC-file can be considered as an internal tendon or as a free tendon. 

- Storeys 
Storeys can be imported. 

- Geometry 
Geometry as members means that all objects that are defined via a sweptsolid representation will 
be imported as native SCIA Engineer elements (1D-/2D-members). 
Geometry as reference model means that all objects will be imported as general volumes. 
Analysis shape only – If ON all elements are imported without clipping. If OFF a full structural 
shape of the model is imported. 
Run member recognizer will convert after the IFC import all supported members (beam, columns, 
walls and slabs) from general volumes to native SCIA Engineer elements. After conversion a report 
with a result is shown. 

- Material table 
If the material names in an IFC file are not in accordance with code names it is necessary to define 
a material conversion table in the Import dialogue. For the first opening of a file with defined 
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material table there is button [Choose file…]. For following modifications, button [Edit] is available. 
The file has *.con file extension and it is a plain text file, for example: 

[materials] 

; 

Concrete1=C12/15 

Concrete2=C25/30 
The first name is the name of material in the IFC file and the second name is code name of 
material which is used in SCIA Engineer. It is necessary to respect all characters. 

- National code 
As IFC file does not specify any code it is necessary to select it before the import. An actual 
adjusted code is displayed with a national flag. If you want to change it press the button 
[Change...]. 

5) Import 
After confirmation of the IFC Import Options dialogue a progress bar with number of total elements 
and already imported elements is shown. 

 

At the end a report (which can be saved) of the import is displayed. 

 
On the left side there is a list of imported objects with their quantity. On the right side there is a 
place for errors and notifications if they are any. 

What can be imported? 

- Planar walls and plates with openings and constant thicknesses 

- Circular arc walls without openings 

- Plates with arc edges 

- 1D-members with openings 

- Shells, curved 1D-members, beams with haunches and arbitrary members as general solids. 
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Update procedure: 

1) In a to be updated project go to File > Update > IFC 2X3 

  

2) Select an IFC-file in Windows Explorer and confirm by clicking on “open” 

3) Select the import options (see step 4 of import procedure) you want to use. Confirm by clicking on 
OK to start importing the project. 

4) Update 
After confirmation of the IFC Import Options dialogue a progress bar with number of total elements 
and already imported elements is shown. 

 

At the end a report (which can be saved) of the import is displayed.  

 
On the left side there is a list of imported objects with their quantity. On the right side there is a 
place for errors and notifications if they are any. 

5) A comparison is made between the imported project and the to be updated project. 
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REMARKS: The update functionality can help the user to save a lot of time. But the user should be 
aware of some restrictions in the IFC-format such as: 

- IFC describes the volumes of objects. This means that connecting and alligning the structure after 
an update is seen as a modification of the structure. 

- All beam/column nodes are generated during the import. Which implies that after the update action 
these nodes are placed in the groups “New entities” and “Deleted entities”. 

Export procedure: 

1) Open the SCIA Engineer file 

2) Go to File > Export > IFC 2X3 or IFC 2X3 Compressed 

 
 

3) Choose a name for the IFC-file and click on “save” 

4) Select the export options you want to use. Confirm by clicking on OK to start exporting the project. 
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Export options: 

- Project settings 
In coordination view the user can choose between a Sweptsolid or a Boundary representation 
(Brep). 
In Simplified view every object is exported via a Boundary representation (Brep – i.e. faced solids). 
Units – an option for setting a unit for length, the most common used units for export are 
millimeters. 

- Export entities 
You can select which SCIA Engineer objects ( beams, columns,…) you want to export to IFC. 

- Shape representation 
The shape representation (Sweptsolid, Brep, SectionedSpine) can be chosen per structural 
element type.  

- Export 
After confirmation of the IFC Export Options dialogue a progress bar with number of total elements 
and already imported elements is shown. 

 

At the end a report (which can be saved) of the export is displayed. 

  

On the left side there is a list of exported objects with their quantity. On the right side there is a 
place for errors and notifications if they are any. 
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What can be exported? 

- Planar walls and plates with openings 

- Circular arc walls and plates with arc edges 

- 1D-members with openings 

- Shells and curved 1D-members – only with Brep 

- 2D-elements with cut-outs – only with Brep or without cut-outs 

- Parameters with their assigned values defined as entities of 1D-/2D-member properties. 

- Beams with haunches and arbitrary beams – with SectionedSpine or Brep 

BIM Toolbox 

Often after importing a model from another application a structure consists of unconnected general 
solids. That means a structural engineer needs to create SCIA Engineer native members which can be 
connected together and used for the analysis. That all is possible with the BIM toolbox service. 

 
 

Convert 

Via the BIM Toolbox users can convert volumetric elements (i.e. solids) into native SCIA Engineer 
elements (beam, column, plate, wall). This is a necessary step in order to be able to calculate the 
imported project because you cannot generate a mesh (thus calculating) on solids in SCIA Engineer. 
Converting solids into native elements is a quit easy step to do. Simply select those elements and use 
the proper conversion type (for 1D-members  general solid into beam/column, for 2D-members  
General solid into plate/wall). An automatic recognition algorithm detects the associated cross-section 
during the conversion of solids to 1D-members. The same applies for 2D-members in which the 
associated thickness is detected and assigned to it. 
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Below an example of imported solid elements (left side). After conversion (right side) you will obtain 
native SCIA Engineer 1D-members with their associated cross-section. 

Imported solid elements Converted solid elements to native SCIA 
Engineer elements 

  
 

Align 

Aligning the structure after an IFC-import is often needed. The reason for this is the following: 
A model consisting of solids are interconnected based on their volumes. But in analysis software like 
SCIA Engineer it is necessary to have a connection in the member system line for 1D-members or the 
member system plane for 2D-members. The picture below illustrates this problem: 

 
Structural elements can be aligned by moving the nodes of the 1D-/2D-members or the entire 1D-/2D-
member to the master planes. This principle will be clarified and used in Example1. 
 
Below an example of not aligned & not connected 1D-members (left side). Via the align functionality in 
the BIM toolbox a connection in 1 node (right side) can be obtained. 
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Not aligned & not connected 1D members Aligned & connected 1D members 

  
 
 

 
The options marked with an arrow are the properties that are usually modified during an alignment 
action. 

1) Alignment information can be shown in a separate window. Also before executing the alignment 
you can see a preview appear in the model when activating “Live Preview”. 

2) Master planes can be chosen on which you want to align the structural elements to. 

3) The alignment of nodes from one structural type (beam, column, wall, plate) to another structural 
type can be specified 

4) Maximum displacement settings can be specified. This is an important setting because if the node 
to master plane distance is higher than this value no alignment can occur for that node. 

5) Display options can be modified 

6) Advanced settings. 
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Evaluate – clash check 

This function checks whether two or more entities (solids, 1D and 2D members, reinforcements) 
intersect each other. A new solid is created in the intersection of the entities; this new solid is called a 
collision solid. 

 

 
 

Reasons for using the BIM Toolbox 

The main reasons for using the BIM toolbox: 

- Saves time – using functions convert and align is quicker than creating new entities from general 
solids and connecting unaligned entities manually. 

- Saves work – the imported model created by an architect in other software needs modification for 
the purpose of finite element analysis. Modification by the BIM toolbox is the fastest way to create 
a correct analysis model 

- Keeps original structural model – in the same project both the original shape designed by an 
architect and the analysis model created by a structure engineer are kept. This makes it easy to 
compare if both models match. 
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Example 1: Importing an IFC-file 

 

Importing the IFC-file 

*Import the project Example01.ifc (file > import > IFC 2X3) into SCIA Engineer with the following 
import options. 

 
 
After importing the IFC-file you can see that the structure is already converted to native SCIA Engineer 
1D-members and 2D-members because they use the SweptSolid shape representation. Only the pad 
foundations are not converted to native SCIA Engineer objects. 

BIM toolbox 

*Convert the foundation slabs from general solids to native 2D-members via the BIM Toolbox. Select 
all the pad foundations and go to BIM Toolbox > Convert > double click on General solid into plate/wall 
and click on OK to convert them. 
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In the wired view of the model it is clear that this project needs to be aligned in order to be able to 
realize a connection.  

 
*Align the entire project as follows: 
Go to BIM Toolbox > Align > double click on Align 

 
 
Make sure that you tick on the following align properties: Live preview, all master planes.  
When clicking on the current action tick box you can see the preview of the alignment appear in the 
form of blue lines. This gives the user feedback of the chosen alignment settings before running the 
alignment. 
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The master planes that are going to be used can be visualized by going to the tab “Master planes”. 
If you click on planes you can see the master planes appear in the model. 

 
We want to execute an alignment in an orthogonal matter (horizontal and/or vertical). Therefore the 
diagonal master planes shouldn’t be used.  
*Tick off the following master planes. 

 
*Run the alignment 

 
 
Now you have aligned the entire structure as can be seen in the following picture: 
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*The final step is to connect the entire structure via connect members/nodes. Tick on “Check” and 
confirm by clicking on OK. After connecting the members the check structure data will be started. 
Execute the check to delete duplicate nodes. 
 
Now you are done with the modelling part (i.e. importing and converting an IFC project to a calculation 
model). 
 
*Do not close this project as it will be used in example 02 

Example 2: Updating and exporting an IFC-file 

Example 2 builds further on the model obtained in example 01. 
In this example the project of example 01 will be updated by Example02.ifc 

Updating a project via IFC 

*Go to file > update > IFC 2X3: select Example02.ifc 
Use the default IFC import options by clicking on OK 
*In the project comparison window deselect the changes & deleted entities of the original project. The 
changes (in yellow) are detected because we have aligned and connected the project in example 1. 
We do not want to undo these actions therefore you should untick these. 

 
* Next click on accept to import the new entities. 

BIM Toolbox 

* Use the BIM Toolbox to align and connect the newly added elements in the project. 
The end result should be as follows: 
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Analyzing the structure 

*Optional step: add a subsoil under the pad foundations + add a surface load on the slab  calculate 
the project. 

Exporting the modified structure to IFC 

*Once finished the project can be exported into a new IFC-file via file > export > IFC 2X3 or IFC 2X3 
compressed. This IFC-file contains all the modifications executed in SCIA Engineer. The draftsmen for 
instance can load this IFC-file into his drawing software (e.g. Allplan, Tekla Structures, Revit 
Structures, …) 

Example 3: Extracting information from a reference model 

 
Example 3 is a project that is made based on the information provided in the IFC-file that is imported 
into SCIA Engineer as a reference model. This can be done in the import options as follows: 
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Importing the geometry as a reference model basically imports the entire IFC-file as solids. These 
solids can provide information such as the position of the HVAC, wall openings, … 
 
*The reference model is already imported in this project. For instance we can visualize the structural 
model in combination with the reference model of the HVAC. This can be done by using the following 
layer activity: 

 
 
*We can examine the central part of the building by activating the clipping box via view > clipping box > 
clipping box on/off 
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Although we do not need to convert the reference model containing for instance the HVAC into native 
SCIA Engineer object but we can leverage this information into the structural model. For instance the 
position of the HVAC channels can be used to apply the proper loading (self-weight) on the structural 
elements (slabs). Openings that need to be provided into the concrete walls for these HVAC channels 
can be localized and inputted easily.  

BIM+ platform 

 
The bim+ platform facilitates the workflow of a BIM 
project, providing you with a wide range of features 
for collaboration. This platform operates in the cloud 
(i.e. a BIM server). BIM+ is a service provided by 
Allplan. It is mainly developed for Allplan but users of 
different software (e.g. Revit) should be able to use it 
also because the IFC-format is a vendor neutral 
format. 

 
Regardless of the tool you use, you should always check the IFC files you created yourself or you 
received from planning partners in two respects: 

- Check that the geometry of the building is correct and that the components are  positioned 
correctly. In addition, make sure that the model is complete. 

- Check that the attribute sets (Psets) of the objects include all necessary parameters, attributes 
and pieces of information. 

 
Compared with any IFC viewer, the open bim+ platform provides you with many more features and 
options. You can use the bim+ platform not only to check data but also to collaborate and communicate 
with your planning partners throughout the project. 
 
You can upload multiple IFC models to bim+ and assign tasks, communicate on this platform. The 
communication between all the partners happens via BCF(= Building Collaboration Format). BCF is a 
relatively young format derived from IFC. Whereas IFC as a neutral format is used to exchange models 
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and building information in a BIM project, BCF is the format planning partners and project participants 
use to communicate.  

 

Example project in BIM+ 

A project has been uploaded to BIM+; this can be done in SCIA Engineer via File > Export > bim+ 

 
 
I can see that I have got a task assigned to me, if I click on it I can see that I have to calculate the 
reinforcement of a plate. 

 
 
The structural engineer should calculate the reinforcement of that plate in SCIA Engineer and export 
these reinforcement areas via an .asf-file to Allplan. This can be done in SCIA Engineer when obtaining 
the reinforcement areas by clicking on export to CAD. 
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Once calculated the .asf-file can be attached to the task and the task can have a ‘closed’ status. 

   
The person who had created the task will be notified by e-mail and in Allplan via the BIM+ interface. 
 
More information concerning bim+ can be found on: https://www.allplan.com/en/bimplus.html  
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Part 2: Exchange via the Revit-link 

 
The CADS Revit SCIA Engineer link facilitates the bi-directional 
exchange of members, loads and supports between Revit Structure and 
SCIA Engineer and in doing so plays a vital role in the overall Building 
Information Modelling (BIM) process. A structure modelled in Revit 
Structure can be transferred to SCIA Engineer for structural analysis 
and design using CADS Revit SCIA Engineer link. When the structural 
analysis and design has been completed in SCIA Engineer, the updated 
model can be sent back to Revit Structure. The modelling - analysis - 
design process requires numerous iterations to arrive at the final design. 
CADS Revit SCIA Engineer link will save time by avoiding duplication 
and reducing errors. 

Analytical versus structural? 

The Revit link comes down to exchanging the analytical model between SCIA Engineer and Revit 
Structure. 
In Revit Structure as well as in SCIA Engineer, there are 2 different representations of the 
model in each project. These are the analytic model and the structural model. 
 
The analytical model is used for calculations. It is a model in which a beam or column is 
represented by a single line. The cross-section that belongs to that beam or column is 
assigned to that line, and thus the properties of that beam or column are assigned to that 
line as well. A plate or wall in the analytical model is represented with a plane with no 
thickness, but the material and the thickness of the plate or wall are also assigned to that 
plane. For analysis of the structure (forces and stability), this analytical model is used. 
 
The structural model is used for drawings and shows the volumes. For example in SCIA 
Engineer, you must activate the structural model to see a volumetric representation of the 
entire model. In Revit Structure the emphasis lies on this volumetric representation, but this 
does not ensure a good underlying analytical model at all! In the end, a modeller will use this 
structural model to see how the realization of the project will look like and to create 
drawings etc. 

 
 
Now the problem occurs: when you are using the Revit link between Revit Structure and SCIA 
Engineer, you are actually exchanging the analytical model. The structural (volumetrical) 
model gets neglected and therefore it is important that the analytical model in Revit 
Structure is correctly constructed. So the modeller has to understand the importance of a 
correct analytical model of the project. 
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As you can see in the above figure, a good looking structural model can contain a very bad underlying 
analytical model. The beam is clearly not connected to the columns in the analytical model. 
These issues can be prevented in Revit Structure by maintaining the analytical model or you can 
correct these issues later on in SCIA Engineer via the BIM Toolbox. 
 
REMARK: The reason that the link between Revit and SCIA Engineer only works with Revit 
Structure is because Revit Structure contains an analytical model while Revit 
Architecture does not contain an analytical model. 

The Revit-link 

Before using the link make sure that you have referred/linked the structural template with Revit as well 
as the family paths. 
This can be done in Revit via options > File Locations. 

 
In the above picture you can see a reference to the structural template “Structural Analysis-
DefaultEUROENU.rte” so that the standard families which are related to this template can be used in 
Revit Structure. 
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The same needs to be done for the libraries as follows:

 
 
In Revit Structure, there should be a tab ‘CADS’. This tab is installed by the Revit Structure plug-in. 

 
 

Node format 

The user can define the node format via Options > Node Format. Because the node numbers aren’t 
always generated in Revit Structures. This Node Format will be used for the naming of the nodes in 
SCIA Engineer. 

 
 

Consistency checks 

It is recommended to execute a consistency check before exchanging a model from Revit Structure to 
SCIA Engineer in order to be sure that the analytical model is correctly generated and connected. 
It is recommended to apply the following setting in Revit Structure: 
Go to manage > Structural Settings > Go to the tab: Analytical Model Settings > Tick on ‘Member 
Supports’ and ‘ Analytical/Physical Model Consistency’. 
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Review & export – Review & import 

With the review functionality a model comparison can be made between the current model in Revit 
Structure and the to be imported/exported model. The user has then the possibility to select which 
new/modified/deleted elements should be exchanged or not. This functionality will be clarified with an 
example later on. 

Show Unexported 

The elements that couldn’t be exported can be localized and highlighted in the model via Show 
Unexported. 
 

Select imported 

The imported elements can be chosen based on the following criteria: 

 

Documentation 

If you are searching for extra documentation/help, then the options ‘Getting Started’, ‘Best 
Practices’, ‘Help’ and ‘Check list’ can be of great help to you. Also the option ‘About’ will give you 
the version of the Revit link, but also the release notes (improvements in the last patch of the 
Revit link in comparison with the previous one). 
 

Options 

There are several functions which affect what can be transferred to the SCIA Engineer. These 
functions can be found in the Options dialogue. 
 



Integration with BIM workflows – SCIA Engineer 17 

32 

 

1) National code: If your project in Revit Structures or in SCIA Engineer uses for instance Eurocode 
profiles / materials you should choose the Eurocode as national code. 

2) Launch SCIA Engineer:  
YES if you want to use the direct exchange method (project is directly exported/imported and 
opened in SCIA Engineer/Revit Structures. 
NO if you want to use the R2S file exchange method (project is exported into an .R2S-file 
format). 

3) SCIA Engineer version: The used SCIA Engineer version should be specified by browsing to the 
following folder for example: C:\Program Files (x86)\Scia\Engineer 16.1\ 

4) Export selected items only: 
When ticked on: only the selected items will be exported 
When ticked off: the entire project will be exported 

5) Export or import buttons to start exchanging model data 

Mapping tables: 
- Preferred tables: 
In the preferred databases you can set your own preferred mapping tables by modifying its priority. 

- User tables: when a cross-section or material cannot be mapped during the export the Revit-link 
will prompt the user to map it manually. After mapping it manually this mapping information will be 
stored in the user table so that it can be re-used in the future. 
- Section Parameter Mapping: In here you can map the parameters of parametrized cross-sections 
if present in the project. 

6) Mapping tables: In this section the mapping (= linking) of materials and cross-sections between 
SCIA Engineer and Revit is defined. 

7) Options: in the options dialog you can specify which objects or results should be exported/imported 
or modified when using the Revit-link. 

Methods of exchange 

There are two ways in which a model can be exchanged between Revit Structure and SCIA Engineer:  
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- Direct exchange method: In this method the model is transferred directly between Revit Structure 
and SCIA Engineer without the need of any data exchange file (*.R2S-file).  
 

Revit Structure to SCIA Engineer SCIA Engineer to Revit Structures 

  
  

- R2S file exchange method: If you have either Revit Structure or SCIA Engineer licensed on your 
system then you can exchange modes using a data exchange file in the *.R2S format.  

 

Revit Structure to SCIA Engineer SCIA Engineer to Revit Structure 
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Example 4: R2S File Exchange Method 

Exporting a Revit Structure project 

To prevent errors that can occur, make sure that all users have full read & write rights on the 
following folders (go to properties -> security), and make sure they are not ‘read-only’: 
- C:\Program Data\CADS\Revit to Scia Engineer\ 
- C:\Program Files (x86)\Scia\ 
 
In Example 4 a simple steel frame is modelled in Revit Structures. 

 
*Now change the view towards the analytical model. 

 
This is the model that will be transferred by the Revit link. If there is nothing here, then you are 
not using the correct families. Also if the lines of the columns and the beam do not connect, then 
you must manually change the analytical model to correct this. 
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Also make sure that each element which you want to transfer, has ‘Enable Analytical Model’ 
activated, and that there is a ‘Structural Material’ indicated for that element. Revit Structure does 
not require a material for each element, but the Revit link does require that each element that you 
want to transfer has a material. 

 
It can be possible that you must still indicate a material. To do this, click on the three dots in the 
same line as ‘Structural Material’, and choose the desired material. 
 
* Go to the CADS tab > Options in Revit Structure in order to export the project to SCIA Engineer. 
* Export the project via the R2S File Exchange Method (.R2S-file) by using the following settings: 

 
As long as “Launch SCIA Engineer” is set to NO the R2S File Exchange Method will be used. 
 
*You will see the ‘CADS Revit SCIA Engineer link’ progress window appear. Here you can see which 
items (beams, columns, plates, load cases ...) are recognized by the link. It will also ask where to 
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save the .R2S file (which is the file you must import in SCIA Engineer). Save the ‘SCIA Engineer r2s 
file’ as ‘Example04’ and choose ‘Save’. 
 
Once the transfer has started, the link will give a message when it does not recognize a certain 
item. The link is based on names. In this example, the Revit material ‘Steel, 45-345’ cannot 
automatically be linked to SCIA Engineer. This link is called ‘mapping’, and must be added manually 
if the link cannot do the mapping automatically.

 
 
*Click ‘Yes’ and choose the correct ‘SCIA Engineer Material Name’ (for example S355). 

 
Once the export is completed, you will be able to see the total number of items recognized for 
each category, and the amount which has been successfully exported. Not that the separate 
elements (structural columns and structural framings) must have analytical lines to be recognized. 
On the right side of the window, you will be able to see the log file. This explains how the mapping 
has been done for the different materials and cross sections. 
- Revit Material “Steel, 45-345” is mapped as “S 355” based on user mapping 
- “HEA300” is mapped as “HE300A” 
This log file can also be saved by using the option ‘Save Log’ (in the bottom right corner of the 
window). 
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If we would not have mapped this material (by clicking ‘no’ for the question to add this material), 
then all elements that used this material, would not have been exported. 

Importing in SCIA Engineer 

*Open SCIA Engineer, and import the .R2S file: 

 
SCIA Engineer will ask for a code. The .R2S file is mapped to the SCIA Engineer materials for the 
code that was configured in the Revit Link options (in this case the EC-EN). We will use the EC-EN 
in SCIA Engineer as well (if necessary, ‘Add’ the correct code). Click ‘close’ if you have the correct 
code. 
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Now you will see the imported items in SCIA Engineer. 

 
Under ‘load cases’, you will also find the load cases which have been transferred from Revit 
Structure to SCIA Engineer. These are the same 9 load cases that you could see being exported by 
the Revit link (2 pages back). The ‘Load Natures’ from Revit Structure are imported as ‘Load 
Groups’ in SCIA Engineer. 
SCIA Engineer: 

 
Revit Structure: 

 
*Now we will change the project in SCIA Engineer, and then export it back to SCIA Engineer. Copy 1 
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beam and 1 column, and change 1 cross-section to HEA600. 

 

Exporting from SCIA Engineer 

 
*The file will be saved as an .r2s file again. This time we’ll name it ‘Example04s.r2s’. Be sure to 
unselect everything in SCIA Engineer first, otherwise only the selection will be exported. 

Importing in Revit Structure 

*Open Revit Structure (with an empty project) and go to the ‘CADS’ tab. Choose ‘Import’ (which you 
can find both in the CADS-tab as in the options dialogue) and select the ‘Example04s.r2s’ file. 
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It could happen that that the ‘HE300A’ from SCIA Engineer is not imported into Revit Structure. It is 
mapped correctly, because it recognizes that the HE300A profile is linked to the ‘H-Wide Flange-
Column’ family, but the problem is that the Revit link itself cannot find this family (Error: “The revit 
family file ‘H-Wide Flange-Column’ is not found to load the section ‘HE300A’ ”). In those cases you 
should specify the path to your Revit families (e.g. C:\ProgramData\Autodesk\RVT 2017\Libraries\UK) 
as follows:  

 
If the import went successfully, you will see the same structure as you had in SCIA Engineer: 
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Example 5: Direct Exchange Method 

Example 5 consist of a steel fabrication hall with an administration part in concrete. 
 

 

Directly export a Revit project in SCIA Engineer 

*Export the project via the Direct Exchange Method to SCIA Engineer. This can be achieved by 
applying the following setting in the options dialog.  
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*During the export you will be prompt to manually map the material ‘Metal – Acier’, click on yes to map 
it correctly to the SCIA Engineer material S235 

 

 
 
* A manual mapping of the material ‘Concrete – Cast-in-Place Concrete’ should be done. Correctly link 
it to the SCIA Engineer material C30/37 
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Notice that the project in Revit Structure is automatically exported and opened in SCIA Engineer 
without the use of the R2S-file format. This Direct Exchange Method can be used in both directions 
(import and export) by using one of both buttons in the options dialog. 

 
 
*Once opened in SCIA Engineer add fixed supports for the columns and hinged line supports for the 
walls. 
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*Next connect the entire structure as follows: 

 

 
*Execute the check of structure data and click on continue 
*Add a surface load on the roof under loadcase DL1 with a value of -2kN/m² 
*Refine the mesh size of 2D-elements from 1,00m to 0,3m in the mesh setup 
*Now the Engineer can execute the linear calculation and obtain for example the displacement Uz for 
loadcase DL1 

 

Updating a modified project 

*Modify the cross-section of the IPE220 beams into IPE500 beams. 
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*An update of the changes made in SCIA Engineer can be send to Revit Structure via the “Review & 
Import” functionality. 
 

 
 
Once clicked on it a communication between Revit Structure and SCIA Engineer will be established in 
order to run a model comparison of the changes (cross-section, geometry, new elements, deleted 
elements,…). 
 
The following window will appear which summarizes the differences between the updated model of 
SCIA Engineer and the current model in Revit Structures.

 
The user can identify visually what has been changed and decide whether these changes should be 
imported or not. 
*Click on import to start importing these changes into Revit Structures.  
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Imported elements can be highlighted into the model via the functionality “Select Imported”. In our case 
we can visualize all the changes (in cross-section) via the option “All changes”.

 
 
An update with model comparison can be performed also in the other direction (Revit Structure  
SCIA Engineer) via the functionality “Review & Export”. 
If for some reason certain elements cannot be exported you can always visualize them via the 
functionality “Show unexported”. 
 

Mapping materials and cross-sections 

The mapping between Revit Structure and SCIA Engineer is based on tables. There are three types of 
mapping tables namely: user-defined table, tables based on national codes and mapping rules. 
For most standard materials and cross-sections from Revit families, the tables between SCIA 
Engineer and Revit Structure are implemented. If you are using different families then the 
standard Revit Structure families, then manual mapping becomes much more necessary. Also 
families provided by separate Revit Structure dealers are considered as personal families (and not 
standard families). The upside is that mapping must be done just once for each material and cross-
section that must be mapped (since the link stores the mapping in a file). 
This example is about configuring the mapping and can be used on a simple example with a 
nonstandard analytical family. This mapping is always based on the names of materials and 
cross-sections. 

Preferred tables 

This dialogue defines which predefined tables should be used. There are mapping tables 
based on national codes and also user defined table in the list. 

 
The top tables in the list have the higher priority. The mapping is done preferably by them. 
The checkbox can deactivate tables for mapping. The buttons Up and Down is used for 
moving the selected table in the list (and thus changing their priority). 
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Mapping rules 

The mapping rules can be used when mapping by tables is not sufficient anymore. These 
mapping rules were the original (old) way to configure the mapping. 

 
 

Source and target rules 

The mapping rules become necessary when: 

- There are too many items for mapping  

- There is no sufficient table and the mapping has to be done manually – some specific project or 
national code. 

 
The box with choices can set the mapping rule when the mapping tables become insufficient.  
There are three options: 

- “Do not use”: if the mapping tables are insufficient, the mapping rules will NOT be used. 

- “Use If not found”: if the mapping tables are insufficient, the mapping rules will be used. 

- “Use mapping rules only”: the mapping tables are ignored, and ONLY the mapping rules will be 
used. 
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What is the purpose of the mapping rules exactly? 

The mapping rules define mapping between parts from Revit Structure and parts of SCIA Engineer. 
Each rule defines the name in Revit Structure (Source table) and the name for SCIA Engineer (Target 
table). This is not based on libraries from Revit Structure or SCIA Engineer but on exact naming. 
 
For example, if I open the “Source Mapping Rule” (or “Mapping Rule For Source Configuration”), I can 
select a line in the table, see the Revit Structure name of the section in the preview, and the parts of 
the name will be explained in the selected line. 
E.g.: L200X100X150 has ‘Type Name’ L, it is an L(AISC)-section in SCIA Engineer, and its 
name can be decomposed (with Delimiter ‘X’): 

- TypeName: L200 
- Depth = 100 
- Width = 150 

 
 
For a section from SCIA Engineer, the same thing can be done. You will see that the Target Type 
Name from the Source configuration matches the Type Name from the Target configuration. 

 
 
The explanation of the name composition: 

 
 

Revit family mapping 

The Revit family mapping dialog specifies the mapping of the section types to the Revit family 
names. This will result in the following procedure: 
- An imported (or exported) cross-section will be recognized as a certain section type by 
the ‘Mapping Rules for Source or Target Configuration’. 
- The ‘Revit family mapping’ will link this section type to a family. 
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Revit family path 

The Revit family path dialogue allows the user to define the path of another Revit family 
which is saved on the computer. The family mapping configuration (mentioned above) will be 
able to also look in the folders defined in this setting. 

 
REMARK: The Revit link needs full read & write rights on this folder, and thus it cannot be set to ‘read-
only’. 
 

User tables 

It is possible to look at the tables (mentioned in the preferred tables) in detail. This is done in a dialog 
which shows the whole database of mapping. These tables are based on the libraries taken from Revit 
Structure and SCIA Engineer. 
To access them, you can use “User Table” in the options window. 
 
This will result in the following table, where the different tables can be chosen. For each table you will 
be able to see how different cross-sections (or materials) are mapped. 
 



Integration with BIM workflows – SCIA Engineer 17 

50 

 
 
The user table is clearly user defined. New mapping rules can be added in the user table by using the 
dialogue button “Add”. Then the user can select the section name in Revit Structure and the 
corresponding name in SCIA Engineer. A window ‘Add Cross Section To User Table’ will appear, and 
you must follow the next steps (to map for example HE300A from SCIA Engineer with HEA300 from 
Revit Structure) 
 
*Supporting Mapping Database: choose ‘Belgium Columns’ (or ‘Europe Specific Sections’ or 
‘Netherlands Columns’) 
*Family Role = Column 
*Family Name = H-Wide Flange Column 
*Section Name = HEA300 

 
Then for the options under ‘SCIA Engineer’: Catalog Name = Rolled, and search the section 
HE300A. You should have the following options: 

 
 
*Afterwards click on OK. 
*You will see that there is a new line in the mapping table. Now click on ‘Save’ to keep this 
new mapping. This will now always be used if you use the Revit Link 
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You can see how the ‘Add Cross Section To User Table’ is translated to a single line in the 
‘User Table’: 

 
 
If you look at other tables (by choosing different ‘Databases’), then you can see that entire 
series of mappings are predefined by the system. 

 

 
If the user table contains rules with the higher priority than it must be moved in the list to 
the top. If different tables contain the same mapping, then the table that is highest in the list 
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will be used in advance to execute the mapping. 

 
 

Section Parameter Mapping 

The parameters in Revit Structure of used parametrized cross-sections can be mapped with the SCIA 
Engineer parameters via Section Parameter Mapping  

 



Integration with BIM workflows – SCIA Engineer 16 
 

53 

Part 3: Exchange via the Tekla-link 

The Tekla-link 

This link is continually improved after every release of SCIA Engineer 
but at the moment the IFC exchange proves to be a better solution then 
the Tekla-link. If IFC doesn’t offer a solution you can consider using this 
link as an alternative for IFC exchange of Tekla Structures projects. 
  
 
 
 

The link is based on Tekla Structure API and it supports the export of: 

- Geometry of straight beams and columns (beginning- and end-nodes) 
- Materials using the mapping database 
- Cross-sections due to mapping database or geometrical profiles (except twin profiles) 
- Eccentricity, ey,ez 
- Member system-lines 
- Welded cross-section, 
- Hinges. 

 
Although the Tekla-link is a bidirectional link it uses two different file formats for the exchange. If you export 
from SCIA Engineer to Tekla Structures the *.s2t-file format (SCIA2Tekla) is used. If you export from Tekla 
Structures to SCIA Engineer the *.t2s-file format (Tekla2SCIA) is used. The usage of this link will become 
clear by using it in an example. 
 
The main and usually the only thing which is necessary to do is to set the proper path to SCIA Engineer 
which should be used. In the right bottom corner in SCIA Engineer box there is an empty item SCIA 
Engineer Folder it is expected the path to Esa.exe. The rest of paths, e.g. to templates, is set automatically 
during installation. 
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Example 6: Using the Tekla-link 

 
The above steel hall is modelled in SCIA Engineer and will be exported to Tekla Structures. 

Exporting to Tekla Structures 

*Export the file to Tekla as follows: File > Export > Tekla file (an *.s2t-file will be created). 
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*In order to be able to import this project in Tekla Structures it is necessary to open an empty Tekla 
Structures project (otherwise it will not work).

 
 
*Next open Link - SCIA to Tekla 2016 (if Tekla 2016 is your current version) via Start > All Programs > 
SCIA Engineer 16.1 > Link – SCIA to Tekla 2016. It is necessary to select the correct version of Tekla 
Structures in order to obtain a good exchange. 
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*In the SCIA2Tekla-link you will need to select the .s2t-file after selecting it click on “Load data to Tekla 
Structures” to import it in Tekla Structures.

 
 
*Modify the following two beams from IPE240 to IPE360.

 
 

Exporting to SCIA Engineer 

*Export it back to SCIA Engineer as follows: 



Integration with BIM workflows – SCIA Engineer 16 
 

57 

In Tekla Structures go to Analysis & Design > A&D models: Click on New > Brows for export folder > 
select SCIA Engineer as the analysis application > click OK > Click on export.

 
 
*After clicking on export the program will ask you if you want to create load combinations. Click on No. 

 
 
*A standard warning will appear > click on OK
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*Once exported the .t2s-file (Tekla2SCIA) is created which can be used to import the project in SCIA 
Engineer. Open SCIA Engineer and go to file > import > Tekla file: select the .t2s-file

 

Mapping tables 

 
In the right top corner there is a path to mapping table for material and cross-sections. The default 
tables can be changed by the user, then it is necessary to change the Type from Master to User. This 
can be done by modifying both XML mapping tables as follows: 

 
Even if changes are made only in one of the table the type has to be set to User in both files. 
 
Now you can change or expand the content of the mapping tables.  
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Cross-section mapping database 

The particular definition of cross-sections start under the line <CrossSectionsMapping>. 
The definition of each profile conversion starts with <CrossSection id="number"> and ends 
</CrossSection>. Id is only order in the file therefore with each new one please add the previous 
number +1. 

 
The first line defines profile name in SCIA Engineer profile library. The next line says that the profile is 
from Profile Library database . It is the only one which is supported for data exchange with Tekla 
Structures therefor use always the same string. 
 
On the third line there is the id from SCIA Engineer database. Use a number in the following way: 

- number 1 for I profiles 
- number 1002 for L profiles 
- number 5 for U profiles 
- number 6 for T profiles 
- number 2 for rectangle hollow profiles 
- number 3 for circular hollow profiles 

The fourth line defines the material type of  the profile which has to be always steel for rolled profiles. 
On the fifth line there is a name which is used in Tekla structures database. The last line defines the 
profile id in Tekla Structures in the following way: 

- for I profiles number 4 
- for L profiles number 6 
- for U profiles number 8 
- for T profiles number 2 
- for rectangle hollow profiles number 9 
- for circular hollow profiles number 11 

Material mapping database 

The particular definition of materials start under the line <MaterialsMapping>. The definition of each material 
conversion starts with <Material id="number"> and ends </Material>. Id is only order in the file therefore with 
each new one please add the previous number +1. 

 

The first line defines material name in the SCIA Engineer material library. The next line defines the id from 
the SCIA Engineer database. Use a number (for EC-EN) in the following way: 

- number 1 for steel material - S 235 
- number 2 for steel material - S 275 
- number 3 for steel material - S 355 
- number 65 for concrete material - C12/15 
- number 66 for concrete material - C16/20 
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- number 67 for concrete material - C20/25 
- number 68 for concrete material - C25/30 
- number 69 for concrete material - C30/37 
- number 70 for concrete material - C35/45 
- number 71 for concrete material - C40/50 
- number 72 for concrete material - C45/55 
- number 73 for concrete material - C50/60 
- number 74 for concrete material - C55/67 

On the third line is the code definition in a format which is used in SCIA Engineer. The fourth line indicates 
the Tekla Structures material type. The last line defines the Tekla Structures name. 
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Part 4: Other formats for exchanging model data 

XML 

The general text format XML has been implemented in SCIA Engineer. This format can be used to obtain 

easily the information about project input data or calculation results. The format makes it possible to modify a SCIA 

Engineer project and even create a new SCIA Engineer project including the new structure and additional data. 

This can be achieved not only by means of the text file in XML format, but also through the 

programming language that supports COM interface (C++, Visual Basic). 

How advantageous is that, following the established rules, the user can define his personal format. 

He can very simply by using an interactive graphical environment, select which data will be stored in the 

final text file and in what order. 

Another interesting feature - useful mainly for programmers of extension modules – is that one can 

define his own data structures in the SCIA Engineer database and process these data using the XML format. 

Example 7: Creating XML-data 

Input of geometry 

*Create the following structure in SCIA Engineer. 

 

Loads 

LC1: Self weight 
LC2: Permanent > line force on roof beams 2kN/m 
LC3: Variable > line force on roof beams 1kN/m 

Load Combinations 

CO1: EN-ULS Set B 
CO2: EN-SLS Characteristic 
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Export structure data to XML 

After creating the load cases and load combinations and applying these on the structure we can create 
the XML-file. 
*This can be done via Tools > XML IO Document 
It will ask you to load a template. SCIA Engineer has some standard templates in which you can 
choose from. 

 
 
*Click on cancel in order to not use a template but to create a new XML-file from scratch. 
*Click on new to start adding items in your XML-file 

 
 
REMARK: The order of the added items is VERY important in an XML-file because the XML-file will be 
read from top to bottom. For example you cannot define a load case before defining the load groups 
because the load group is a property of the load case. This can result in errors when using the XML-
file. Another example is that you cannot input a beam without prior inputting the cross-section and the 
nodes because these are properties of that beam. Always keep the logical order in mind so that you 
obtain a working XML-file which can be used in SCIA Engineer. 
 
*Try composing an XML-file which contains the entire structure (supports, columns, beams) as well as 
the load cases, load combinations, applied loads. 
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The below picture should be the end result. 

  
 
*Before exporting this data to XML make sure that the content is fully regenerated. 

 
 
*click on export and navigate to the folder in which you want to export this data to XML. 

 

Modify an XML-file 

 
*Open the generated XML-file with Notepad (or even better with Notepad++). 
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*Modify cross-section CS1-HEA200 to an HEA300 profile. This can be done via a replace action 
(Ctrl+F).

 
This is very basic editing of content in an XML-file. More advanced users would create tools that 
generates/modifies XML-data based on user input in Microsoft Excel for example. 
 
*Save the modified XML-file (Ctrl+S) 

Update the structure with XML 

*Update the current project with this XML-file via File > Update > XML-file 
Notice that the project is update (i.e. CS1 is changed from HEA200 to HEA300). 
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AutoCAD files dwg/dxf 

AutoCAD files can be imported in SCIA Engineer and also SCIA Engineer models can be exported to 
AutoCAD via .dwg/.dxf 

Example 8: Importing AutoCAD files 

*Open an empty project in General XYZ with steel as material. 

Importing AutoCAD files 

*Import the Example08.dwg via Structure > Modelling/Drawing > Import DWG, DXF, VRML97 

 
The above window will appear which visualizes the AutoCAD file. In this window you can perform 
certain manipulations if needed such as: 

- Connecting curves 
- Connect solids 
- Solid smoothing 
- Import a selection 
- Enabling/Disabling layers or entities 
- Modifying the insertion point 

*Click on import all and insert it in the origin (0;0;0) 
*Convert the lines into the following structural entities: 

- Columns HEA300 
- Diagonals HFLeq40x40x4 
- Beams HEA220 

This can be easily done via the ‘select line’ functionality. See an example below for modelling the 
columns. 
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Exporting or creating AutoCAD files from SCIA Engineer can be done via File > Export > Graphic 
Format 

StepSteel 

SCIA Engineer allows for both import and export of StepSteel files. In addition to the analysis model, 
also the structural model can be imported and exported. 
 
The interface provides for the exchange of data with StepSteel and is based on the following 
references: 
 
Standardbeschreibung Produktschnittstelle Stahlbau 
Teil 1: Emphehlungen für den Anwender 
Teil 2 : DatenModell 
Teil 3 : Implementierungsbereiche und Konformitaetanforderungen 
 
DSTV – Arbeitsausschuss EDV 
 
April 2000 
 
The implemented EXPRESS-scheme is PSS_2000_04.exp 
 
It is recommended to use IFC instead of .stp because the development for it has stopped. You can 
do currently more with IFC-files then with .stp-files. 
 
Exchanging files via StepSteel can be done as follows: 
File > Import > StepSteel 
File > Export > StepSteel 
 
REMARKS:  

- Only steel frame structures (i.e. structures composed of 1D members) can be imported/exported 
through the StepSteel format. 

- Only the PSS_2000_04 file scheme is supported others aren’t (e.g. Automotive scheme,…) 
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APPENDIX 1: Revit-link FAQ’s 

Where are the mapping databases stored? 

Question: The Revit link uses mapping between materials and cross-sections of Revit 
Structure and SCIA Engineer. This mapping can be edited in the user table. Can I create my 
own mapping table? Or copy these mapping tables to another computer? 
 
Solution: The mapping tables are stored in the following folder: 
C:\ProgramData\CADS\Revit To Scia Engineer\Revit 2017\Databases. 
You can create your own mapping tables by creating your own xml file and placing it in this 
folder. You will see your own mapping table in the Revit link if there are no errors in it. 
Error: if you use the same mapping twice in the same file. 
Error: if you refer to a material that is not in the SCIA Engineer templates (placed in 
C:\ProgramData\CADS\Revit To Scia Engineer\Revit 2017\Templates\Sen). 

Problems due to user rights 

Access to “C:\Program Data\CADS\Revit to Scia Engineer\Revit 2017\Databases” is 
denied 

Description: When you want to indicate SCIA Engineer materials or when you want open the 
options of the CADS plug-in the access is denied. 
 
Solution: Go to C:\Program Data\CADS\Revit to Scia Engineer\Revit 2017\Databases and add the 
current user under the properties -> security. Also make sure that the folder isn’t ‘read-only’. 

Problems during export in Revit Structure 

Export Revit: “Material is null, hence not set.” 

Description: When exporting in Revit Structure, several elements are not exported, and in the 
log file, you will see the following message: 

 
Solution: The material is null when you have selected an element to be an ‘analytical element’, but you 
do not have given it a material in Revit Structure:
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Export Revit: How do I find an element mentioned in the log file?  

Questions: During export, there is a problem with a certain element. If I know how to fix it, 
then how can I find this element?  
 
Solution: 
1. Not exported items can be selected via ‘show unexported’. 
2. The element ID can also be inputted directly. If you go to ‘Manage > Select by ID’ in Revit Structure, 
you will be able to input the ID number and the element in question will be highlighted in the model. 

 

Export Revit: the object is not supported by the Revit link 

Description: The model is not exported at all. 
 
Solution: Only analytical elements can be exported. If the model contains any architectural 
entities, then they won’t be exported to SCIA Engineer. This also applies for elements for 
which ‘Enable analytical model’ has not been ticked on (we refer again to the introduction in 
the first pages of this document). If the model is created in Revit architecture then the model must be 
edited in Revit Structure in such a way that the objects are switched to the analytical objects. 
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